Gadget

This content is not yet available over encrypted connections.

SQL-Ledger ERP

http://www.sql-ledger.com/


SQL-Ledger installation tutorial

What is sql-ledger?

- sql-ledger is semi complete ERP application can let you manage your inventory, HR, general ledger, and production management.

- sql-ledger is written in perl and uses Postgresql as a database

How to install sql-ledger on linux ubuntu7.10:

1- install postgresql:
Installs the database server/client, some extra utility scripts
$ sudo apt-get install postgresql postgresql-client postgresql-contrib
(Optional) To install GUI manager for postgresql
$ sudo apt-get install pgadmin3

2- change admin account in the database
to reset the password for the ‘postgres’ admin account
$ sudo su postgres -c psql template1
template1=# ALTER USER postgres WITH PASSWORD 'password';
template1=# \q

3- change the password of unix postgres admin
delete existing password
$ sudo passwd -d postgres
$ sudo su postgres -c passwd
use the password of step 2

4- setup postgres admin pack
$ sudo su postgres -c psql < /usr/share/postgresql/8.2/contrib/adminpack.sql

5- Adapt the configuration file
$ sudo gedit /etc/postgresql/8.2/main/postgresql.conf
change:
#listen_addresses = 'localhost'
to:
listen_addresses = '*'
change:
#password_encryption = on
to:
password_encryption = on
Then save the file and close gedit.

2- install apache2 server

$ sudo apt-get install apache2

apache configuration file place is:

/etc/apache2/apache2.conf

3- install sql-ledger

$ sudo apt-get install sql-ledger

the setup path of sql-ledger is:

/usr/local/sq-ledgercreate the file /etc/apache2/sql-ledger-httpd.conf in the same location where httpd.conf is and copy the next section into the file Alias /sql-ledger /usr/local/sql-ledger/ <Directory /usr/share/sql-ledger> AllowOverride All AddHandler cgi-script .pl AddDefaultCharset On Options ExecCGI Includes FollowSymlinks Order Allow,Deny Allow from All </Directory> <Directory /usr/local/sql-ledger/users> Order Deny,Allow Deny from All </Directory> edit httpd.conf and add # SQL-Ledger Include /etc/apache2/sql-ledger-httpd.conf



1 comment:

  1. REQUIREMENTS
    Web server (Apache, thttpd 2.22+, boa, AOL server, ....)
    Perl 5+
    SQL Server ( PostgreSQL 7.1+, )
    Database Independant Interface DBI
    Database Driver for SQL server DBD ( DBD-Pg, )
    LaTeX (optional)
    The required software packages are available in packaged format on most modern distribution.

    ReplyDelete